近日把WordPress升级到2.31版本,发觉WordPress自带的widget实在不符合我的需求,因为widget不支持插入PHP代码,于是乎便在网上找了下侧边栏插件,发觉Sidebar Widgets插件确实不错,不过改动的代码太多,似乎拖慢了WordPress的整体打开速度。

于是便找到了Executable PHP widget,这个插件写的相当不错,但使用过程中发现此插件写的有问题,会造成模板拉升变形。我便修正了插件错误,顺便汉化成了中文,特此共享出来给大家。

插件介绍:

Executable PHP widget是一款WordPress侧边栏加强插件,可以在侧边栏插入PHP代码,最多可以支持9个PHP代码模块,由国外作者ottodestruct.com开发,本人修正代码及汉化,版权归原作者所有。

使用说明:

首先下载本插件上传到/wp-content/plugins/ 目录下并启用,然后进入 外观 –widgets 管理本插件。效果见本博客侧边栏。

下载地址:Executable PHP widget汉化中文修正版


本文章由雨豪博客撰写,采用CC授权分享,转载时请注明原文链接。
本文链接: http://www.wx35.cn/archives/489/

随机文章

Comments

5 Responses to “Executable PHP widget汉化中文修正版”

  1. 徐果萍 on 十一月 1st, 2007 1:37 下午

    汗,你这篇文章的点击率还真高呢?

  2. 雨豪 on 十一月 1st, 2007 6:48 下午

    统计插件有问题,暂停使用!

  3. cxy152376 on 十一月 4th, 2007 7:12 上午

    汗.你博客一定用的国内空间

    我从国外虚拟注记 wget 这个插件速度几乎为0
    没办法,只有下载到本地再FTP上传.

    还有,您应该压缩为zip格式的.
    不然Linux下默认无法解压

  4. Wordpress调用Gallery图片 | cxy152376 blog on 十一月 4th, 2007 8:14 上午

    […] Text Widget 不支持 PHP代码,找了一个Executable PHP Widget插件,安装后插入一个PHP code […]

  5. 雨豪 on 十一月 4th, 2007 12:59 下午

    cxy152376,我博客使用的确实为美国主机,wget不能标记为0的问题,很可能是主机商不支持某些组件所至,请使用WEB下载即可。