环境测试二台ROS2.96的路由。电信(单线)IP:219.159.78.68(以下就称为A机内网IP段192.168.88段) 网通(单线) IP:219.159.78.87(以下就称为B机内网IP段192.168.0段)
好了看我的说明:
A机设置:先在AB机之间建一个虚拟通道连接方式用IPIP。
[admin@219.159.78.68] interface ipip> add local-address=219.159.78.68 \
remote-address=219.159.78.87 disabled=no
[admin@219.159.78.68] ip address> add address=10.0.0.1/24 interface=ipip1 把10.0.0.1这个IP分

配给IPIP1这块虚拟网卡
B机设置:
[admin@219.159.78.87] interface ipip> add local-address=219.159.78.87 \
remote-address=219.159.78.68 disabled=no
[admin@219.159.78.87] ip address> add address=10.0.0.2/24 interface=ipip1 把10.0.0.2这个IP分配给IPIP1这块虚拟网卡
——————————————————————–
通过这样设置就可以在A机的命令控制台里ping 通10.0.0.2(也就是B机的虚拟网卡的IP) 这个IP了。基本上AB机的虚拟通道就算建立起来了。
然后在A机的IP routes加规则
[admin@MikroTik] ip route> add dst-address=192.168.0.0/24 gateway=10.0.0.2
———————————————————————
然后把下面这个路由表导入(Copy到记事本保存为*.RSC格式导入)(默然提供的路由表在此十分感谢)
/ip route
add dst-address=59.80.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.0.0.0/13 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.8.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.10.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.12.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.13.0.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.13.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.16.0.0/12 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.208.0.0/13 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.216.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=60.220.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.4.64.0/20 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.128.210.0/24 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.133.0.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.134.96.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.134.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.135.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.136.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.148.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.158.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.156.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.158.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.159.0.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.161.0.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.161.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.162.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.167.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.168.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.176.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.179.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.180.13.0/24 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.180.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.181.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.182.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.189.0.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.237.148.0/24 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.96.0.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.94.64.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.97.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.98.0.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.99.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.102.128.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.102.224.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.106.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.107.0.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.108.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.110.0.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.110.192.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.111.128.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=203.93.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=203.175.192.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.12.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.14.160.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.14.192.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.15.0.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.15.128.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.21.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.22.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.45.128.0/20 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.51.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.52.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.72.96.0/20 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.73.32.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.74.96.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.74.128.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.78.0.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.82.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.95.192.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.97.245.0/24 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.151.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.158.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.163.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.4.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.21.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.62.0.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.104.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.106.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.108.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.141.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.142.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.154.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.156.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.158.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.159.0.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=220.192.0.0/12 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=220.248.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=220.250.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.12.128.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.208.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=222.173.101.0/24 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=222.173.102.0/23 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=222.172.104.0/22 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.96.64.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.7.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.8.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.12.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.24.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.28.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.56.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.60.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.67.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.68.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.0.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.4.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.6.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.7.0.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.7.64.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.7.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.8.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.10.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.11.0.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.11.128.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.11.192.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.12.0.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.13.0.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.13.64.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.13.128.0/17 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.14.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.192.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.196.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.198.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.199.0.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.199.32.0/20 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.199.128.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.199.192.0/20 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.200.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.204.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.207.0.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.208.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.212.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=221.216.0.0/13 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=222.128.0.0/12 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=222.160.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=222.162.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=222.163.0.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=162.105.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=166.111.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.112.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.114.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.115.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.116.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.117.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.118.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.119.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.120.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.192.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.194.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.196.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.198.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.200.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.202.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.204.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.38.192.0/18 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.38.64.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.38.96.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=202.4.128.0/19 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.25.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.26.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.28.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.30.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.31.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.32.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.36.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.40.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.42.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.44.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=210.46.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.64.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.66.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.67.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.68.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.69.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.70.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.71.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.80.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.81.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.82.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.83.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.84.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=211.86.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.192.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.193.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.194.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.195.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.196.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.216.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.218.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.220.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.221.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.222.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.224.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.226.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.242.0.0/15 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=219.244.0.0/14 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=218.30.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.129.58.0/24 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

add dst-address=61.53.0.0/16 gateway=10.0.0.2 distance=0 scope=255 check-gateway=ping

—————————————————————–
就是凡是网通的就通过虚拟通道。由B机那里出去
B机的ip routes设置
[admin@MikroTik] ip route> add dst-address=192.168.88.0/24 gateway=10.0.0.2
好了。通过这样的设置虚拟双线就算是完成了。

设置A机:IPIP 图1

为IPIP虚拟网卡分配IP 10。0。0。1:图2

路由表处设置:图3
就是导入上面的那个路由表就OK了

设置A机完毕

B机设置:
设置B机:IPIP 图4
为B机IPIP虚拟网卡分配IP:10。0。0。2 图5
B机路由表处设置:图6



图一

图二

图三

图四

图五

图六


本文章由雨豪博客撰写,采用CC授权分享,转载时请注明原文链接。
本文链接: http://www.wx35.cn/archives/140/

随机文章

Comments

Comments are closed.